Bug 62

Summary: abcde-musicbrainz-tool --command data --discid QGi07LeAr4lqmuMKVn6dZJELpxM- crashes
Product: abcde Reporter: abcde
Component: CD lookupAssignee: Steve McIntyre <steve>
Status: RESOLVED DUPLICATE    
Severity: normal CC: andrew.david.strong
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: All   
Attachments: patch to fix abcde-musicbrainz-tool

Description abcde 2017-04-15 11:04:56 BST
Created attachment 50 [details]
patch to fix abcde-musicbrainz-tool

Calling abcde-musicbrainz-tool --command data --discid QGi07LeAr4lqmuMKVn6dZJELpxM- crashes with the error message 'Can't call method "count" on an undefined value at ./abcde-musicbrainz-tool line 99'

Apparently sometimes $release->release_event_list() doesn't return an empty list but the undef value.

The attached patch checks $release->release_event_list() before calling count() on it and fixes the bug.
Comment 1 Steve McIntyre 2018-02-21 21:49:53 GMT
Thanks for the report; I think this is fixed already in a slightly different way.

*** This bug has been marked as a duplicate of bug 57 ***